Transmission-vpn with NordVPN | PlexGuide.com

Transmission-vpn with NordVPN

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

Sprort

Citizen
Original poster
Dec 19, 2018
9
5
I recently installed transmission-vpn and made the appropriate ENV changes (OPENVPN_PASSWORD, OPENVPN_USERNAME, OPENVPN_PROVIDER=NORDVPN) but I'm getting an error in the logs related to downloading the .ovpn file from NordVPN.
Code:
2020-01-08 13:39:51 Checking curl installation,
2020-01-08 13:39:51 Removing existing configs,
2020-01-08 13:39:51 Selecting the best server...,
2020-01-08 13:39:51 Searching for group: legacy_p2p,
2020-01-08 13:39:51 Best server : us3942.nordvpn.com,
2020-01-08 13:39:51 Downloading config: default.ovpn,
2020-01-08 13:39:51 Downloading from: https://downloads.nordcdn.com/configs/filesus3942.nordvpn.com,
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current,
                                 Dload  Upload   Total   Spent    Left  Speed,

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0   162    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
100   162  100   162    0     0    157      0  0:00:01  0:00:01 --:--:--   157,
2020-01-08 13:39:51 Using OpenVPN CONFIG :: default,
2020-01-08 13:39:51 Downloading config: default.ovpn,
2020-01-08 13:39:51 Downloading from: https://downloads.nordcdn.com/configs/filesdefault,
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current,
                                 Dload  Upload   Total   Spent    Left  Speed,

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0   162    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   162  100   162    0     0    225      0 --:--:-- --:--:-- --:--:--   225,
2020-01-08 13:39:51 Checking line endings,
2020-01-08 13:39:51 Updating configs for docker-transmission-openvpn,
Starting OpenVPN using config default.ovpn,
Setting OPENVPN credentials...,
adding route to local network 172.17.0.0/16 via 172.17.0.1 dev eth0,
RTNETLINK answers: File exists,
Options error: Unrecognized option or missing or extra parameter(s) in /etc/openvpn/nordvpn/default.ovpn:1: html (2.4.7),
Use --help for more information.,
mknod: /dev/net/tun: File exists,
Any help with this would be greatly appreciated!
Post automatically merged:

I have removed OPENVPN_CONFIG and added NORDVPN_COUNTRY=US NORDVPN_PROTOCOL=TCP NORDVPN_CATEGORY=P2P
I am no longer receiving the error posted above.
The container seems to hang on "Healthy" after a lengthy "Starting", but it's still not actually running or usable.

EDIT:
Transmission appears to be working fine now! Removing and adding the ENV's listed above seemed to work.
 
Last edited:
  • Like
Reactions: 1 user

skijbal

Experienced
Oct 4, 2018
84
14
I was running into the same problem and what you did worked. Too bad I only spent two days working on it. SMH
 

cappannonno

Noobz
Oct 5, 2019
1
0
Hi! It is still not clear to me. My transmission-vpn container is hanging on "Healthy" after few hours from the deployment.
I've already set all you suggested env entries. Do I only need to wait?
 

Sprort

Citizen
Original poster
Dec 19, 2018
9
5
Did you remove the OPENVPN_CONFIG environment variable? That one can trip you up if you leave it there. Aside from that it should work, providing you set the proper country code and added the rest of the variables mentioned in my OP edit
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending