Discussion - Trouble getting Traefik to work (Gsuite/Google Domain) | PlexGuide.com

Discussion Trouble getting Traefik to work (Gsuite/Google Domain)

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

0rang3

Noobz
Original poster
Feb 9, 2020
1
0
Hi all,

I am using Gsuite business and purchased my domain through google during sign up. I am using Ubuntu 18.04 LTS in a Hyper-V VM (I also have a GCE VM).

Once PG was installed I started running through the list 1-10, 1 being the setup of Traefik.

I select option 1 "Utilize Traefik - PGBlitz's" and commenced to fill in the required info for 1-5.
On option 6 and 7 I don't exactly know what to put so I skipped it thinking it may not be required.
1581598077614.png
Obviously either the options are required or my DNS entries are incorrect which is possible. (the guide has nothing on configging Gsuite DNS so I tried to emulate the Cloudflare settings)
It is worth noting that portainer is accessible locally.

So my question is this; is the GCE_PROJECT and GCE_SERVICE_ACCOUNT_FILE required? If so, I have my project name, but I have no idea what the service account file is or where to acquire it.
1581598397665.png

FYI I tried the exact same setup in the google cloud platform and get the exact same issues so I do believe it is unrelated to local firewall settings.

Thanks for any assistance!
Post automatically merged:

bump
 
Last edited:

tjb1010

Noobz
Jul 2, 2020
1
0
bump bump

I can't find any information on where these values come from or what they even are, on pg or from google searches
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending