Discussion Unifi Controller YAML file

Assists Greatly with Development Costs

hawkinzzz

Full Member
Donor
Local time
12:03 AM
Apr 19, 2019
30
7
has the port been updated from 8088 to 8103? just looked in the portainer unifi set up and i can see 0.0.0.0:8103 -> 8080/tcp does that mean port 8103 is being pointed to port 8080 in the container?
 

hawkinzzz

Full Member
Donor
Local time
12:03 AM
Apr 19, 2019
30
7
OK, So i have now tried http://ip.of.server:8103/inform and it comes through to the unifi controller on the remote server but instead of adopting as it should it shows inform error. when doing SSH - "info" on AP i can see that it says "Server Reject (http://ip.of.server:8103/inform)". So i think i now have the correct port but its not getting through fully!? would anybody be able to help with this?
 

toliman

Junior Member
Local time
11:03 AM
Feb 23, 2019
5
4
Oh boy. Had the same inform trouble as other people, and now SSH'ing trouble on the old AP's (IP's had changed, sic.)

But ... yes, http://unifi.domain:8080/inform worked, even though, like @hawkinnz had, it's not clear if/how the address works/worked, or if modifying the default 8103 -> 8080 in portainer made a difference.
There is a brief STUN error, but that would be PortGuard associated, and it worked around it eventually.

(Mostly because I didn't really want to reboot my home DSL gateway to troubleshoot my home network ... because that would be hilarious to figure out when not at home.)

Anyway, got the POE switch and USG gateway adopted over, and the AP's individiually vis SSH.

For reference, logging in with admin and the SSH password set up in the controller, 'mca-cli' then paste in 'set-inform http://unifi.domain.com:8080/inform' and
'info' should show the new status as Unknown (11) or Server Rejected (), or Connected ()
 

hawkinzzz

Full Member
Donor
Local time
12:03 AM
Apr 19, 2019
30
7
Sorted it! I had to forget the device on my current controller (resetting the device) and forget it on the new controller. I then manually informed the new controller and then it was able to adopt! network back up and running and controlled by the remote server :)
 

toliman

Junior Member
Local time
11:03 AM
Feb 23, 2019
5
4
Will also add, I had some trouble with Unifi post-migrate, with the AP's not being able to send stats via STUN on UDP 3478, using CloudFlare proxying by default, since Cloudflare is Proxying some of the HTTP/HTTPS ports for the subdomain...
but not UDP and not STUN proxying. (In the future, there may be a STUN over TCP relay feature, but it's not supported.)


it's not a Docker problem, but a CloudFlare problem ... which solves so many of those early debugging problems where it wouldn't work right away. So, If only I had this problem earlier, it makes so much more sense due to http/https proxying for different ports, sigh.

HTTP ports supported by Cloudflare:
80 8080 8880 2052 2082 2086 2095

HTTPS ports supported by Cloudflare:
443 2053 2083 2087 2096 8443

anyway, simple solution is to disable the proxy on cloudflare so it's open, exposing the domain/IP, etc.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!

Trending