Discussion - Your docker is not installed or has failed... | PlexGuide.com

Discussion Your docker is not installed or has failed...

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

tieubao81

Citizen
Original poster
Mar 6, 2018
4
1
I can't seem to install plexguide. Everytime I try to install it, I get to about 50% and I get the error: Docker Failure.
Your docker is not installed or has failed.
-Most problems are due to using VPS
-Using an Outdated Kernel
-99% is your VPS provider being SPECIAL
- A modified version of Ubuntu

Try a reboot first and rerun. If it fails ......

I have rebooted and rerun. I was on 16.04 and now I'm on 18.04

[email protected]:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
[email protected]:~#

[email protected]:~# uname -rs
Linux 4.4.0-124-generic

Any help is appreciated. Thanks.

---- Automatically Merged Double Post ----

I can't seem to install plexguide. Everytime I try to install it, I get to about 50% and I get the error: Docker Failure.
Your docker is not installed or has failed.
-Most problems are due to using VPS
-Using an Outdated Kernel
-99% is your VPS provider being SPECIAL
- A modified version of Ubuntu

Try a reboot first and rerun. If it fails ......

I have rebooted and rerun. I was on 16.04 and now I'm on 18.04

[email protected]:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
[email protected]:~#

[email protected]:~# uname -rs
Linux 4.4.0-124-generic

Any help is appreciated. Thanks.
Correction... PlexGuide version is 5.080
 
Last edited:

The Creator

Administrator
Project Manager
Jan 21, 2018
26
16
I can't seem to install plexguide. Everytime I try to install it, I get to about 50% and I get the error: Docker Failure.
Your docker is not installed or has failed.
-Most problems are due to using VPS
-Using an Outdated Kernel
-99% is your VPS provider being SPECIAL
- A modified version of Ubuntu

Try a reboot first and rerun. If it fails ......

I have rebooted and rerun. I was on 16.04 and now I'm on 18.04

[email protected]:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
[email protected]:~#

[email protected]:~# uname -rs
Linux 4.4.0-124-generic

Any help is appreciated. Thanks.

---- Automatically Merged Double Post ----



Correction... PlexGuide version is 5.080
Since you now have UB18 installed; please do a sudo apt-get upgrade -y & sudo apt-get update -y and after those two run this ansible-playbook /opt/plexguide/ansible/plexguide.yml --tags docker18 in order to manually install Docker for UB18 and tell us if any errors persist :)
 

tieubao81

Citizen
Original poster
Mar 6, 2018
4
1


Since you now have UB18 installed; please do a sudo apt-get upgrade -y & sudo apt-get update -y and after those two run this ansible-playbook /opt/plexguide/ansible/plexguide.yml --tags docker18 in order to manually install Docker for UB18 and tell us if any errors persist :)
I no package matching docker error...

[email protected]:~# ansible-playbook /opt/plexguide/ansible/plexguide.yml --tags docker18
[WARNING]: provided hosts list is empty, only localhost is available. Note that the implicit localhost does not match 'all'

[WARNING]: While constructing a mapping from /opt/plexguide/ansible/roles/rcache_un/tasks/main.yml, line 63, column 5, found a duplicate dict key (file). Using last defined value only.


PLAY [localhost] **************************************************************************************************************************************************************************************************

TASK [Gathering Facts] ********************************************************************************************************************************************************************************************
ok: [localhost]

TASK [docker18 : Install required packages] ***********************************************************************************************************************************************************************
ok: [localhost] => (item=[u'apt-transport-https', u'ca-certificates', u'software-properties-common'])

TASK [docker18 : Add official gpg signing key] ********************************************************************************************************************************************************************
ok: [localhost]

TASK [docker18 : Add official repository] *************************************************************************************************************************************************************************
changed: [localhost]

TASK [docker18 : Installing docker] *******************************************************************************************************************************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "No package matching 'docker-ce' is available"}
to retry, use: --limit @/opt/plexguide/ansible/plexguide.retry

PLAY RECAP ********************************************************************************************************************************************************************************************************
localhost : ok=4 changed=1 unreachable=0 failed=1
 

The Creator

Administrator
Project Manager
Jan 21, 2018
26
16
Will have to explore this later due to exams Im having tomorrow + friday... Maybe @Admin9705 can help out here instead?
 
  • Like
Reactions: 1 user

tieubao81

Citizen
Original poster
Mar 6, 2018
4
1
I figured it out.. for some weird reason, when I try to install the Docker repo.. it couldn't find anything for bionic 18.04. Hence it keeps killing it. Looks like the docker repo for bionic is empty... that's probably why it's failing. I install did a apt-get install docker.io and installed it through the ubuntu official repos.

[email protected]:~# docker --version
Docker version 17.12.1-ce, build 7390fc6
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending